When you set up conversions with cart data for automated discounts, that allows Google to measure sales, revenue, and profit from your Shopping ads. After you start using automated discounts, if your online store’s setup changes and no longer meets the requirements, Google can’t accurately measure purchases from your Shopping ads. Depending on the issue, some purchases could result in negative gross profit. If there are issues with your conversion setup for automated discounts that result in missing or incorrect purchase conversions, you’ll be notified in Merchant Center.
Common causes
- The conversion type associated with cart data isn’t a Primary conversion
- Primary conversions don’t measure Purchase events
- Product IDs in cart data don’t match products in Merchant Center
- Cart data doesn’t include a price value, such as 25.00
Fix issues
Use the conversions with cart data diagnostics tool in Google Ads to help you identify and resolve issues.
- In your Google Adsaccount, select the Goals icon and select Diagnostics.
For more details, view About conversions with cart data diagnostics.
To review the steps and requirements to set up conversions with cart data for automated discounts, view one of the following articles:
- If you set up automated discounts in Merchant Center, view Set up conversions with cart data.
- If you set up automated discounts with Shopify, view Set up automated discounts in Shopify Google & YouTube app.
- If you use a different third-party platform, work with your channel partner as described in Working with third-party platforms and channel partners.
Changes to conversions with cart data will be applied within 24 hours.